Embedded Exif-Thumbnails, please a little more ...

Ideas for improvements and requests for new features in XnView Classic

Moderators: XnTriq, xnview

Post Reply
jens116
Posts: 36
Joined: Tue Jul 05, 2005 8:38 am

Embedded Exif-Thumbnails, please a little more ...

Post by jens116 » Thu Jan 04, 2007 2:22 pm

Wow, in Beta 6 I found the solving of the embedded thumbnail problem. Now thumbnails are automatically recreated if saving a modified image and you can do that manually too. Very nice!

The only little thing that I miss further more is creating an embedded thumbnail if there is no one in the exif data - or if there is no exif data, creating exif data including the thumbnail. May be this can be combined with the manually function "(Re)Create Embedded Thumbnails".

Embedded thumbnails are very importent because they accelerate the screen build up for listings especially if the CPU is slow as in DVD-HDD-Recorders.

V 1.90 <x>

User avatar
xnview
Author of XnView
Posts: 31737
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Embedded Exif-Thumbnails, please a little more ...

Post by xnview » Sat Jan 06, 2007 11:38 am

jens116 wrote:Wow, in Beta 6 I found the solving of the embedded thumbnail problem. Now thumbnails are automatically recreated if saving a modified image and you can do that manually too. Very nice!

The only little thing that I miss further more is creating an embedded thumbnail if there is no one in the exif data - or if there is no exif data, creating exif data including the thumbnail. May be this can be combined with the manually function "(Re)Create Embedded Thumbnails".

Embedded thumbnails are very importent because they accelerate the screen build up for listings especially if the CPU is slow as in DVD-HDD-Recorders.
Sorry but currently, i can't add EXIF thumbnail if there is no EXIF or no EXIF thumbnail (1.90 testing is almost finished).
Pierre.

jens116
Posts: 36
Joined: Tue Jul 05, 2005 8:38 am

Re: Embedded Exif-Thumbnails, please a little more ...

Post by jens116 » Mon Jan 08, 2007 9:01 am

xnview wrote:Sorry but currently, i can't add EXIF thumbnail if there is no EXIF or no EXIF thumbnail
I would be interested in the reason why it is not possible. Is there a principle reason? At the present time I use a different program to create EXIF thumbnails and I find no problems.

User avatar
negg
Posts: 87
Joined: Sat Jul 09, 2005 12:09 am
Location: Frankfurt, Germany

Post by negg » Sat Dec 29, 2007 11:23 pm

I just stumbled into the problem that I have a lot of images without exif data. What about this suggestion, to be able to create a thumbnail if none is present when using the "update exif thumbnail" feature that already exists? I think it would be a good idea!
XnView 1.93.4 on Windows XP SP2

User avatar
xnview
Author of XnView
Posts: 31737
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Post by xnview » Mon Dec 31, 2007 8:27 am

negg wrote:I just stumbled into the problem that I have a lot of images without exif data. What about this suggestion, to be able to create a thumbnail if none is present when using the "update exif thumbnail" feature that already exists? I think it would be a good idea!
I need to search a way to do that
Pierre.

Post Reply