Problem with browser (linux) ?!?

Questions, suggestions, and answers for XnView on all Un*x platforms (Linux, HP-UX, AIX, ...)

Moderators: XnTriq, helmut, xnview

Tux Mago

Problem with browser (linux) ?!?

Post by Tux Mago »

<Moderator's note: This topic has been moved>

If I run xnview, I get the menubar with "File Option Info" without problem but as soon as I try to switch to browser (or most others menu options), xnview crash with the following message:

$ xnview
** XnView v1.70 Copyright 1991-2005 Pierre-E Gougelet (Sep 6 2005/15:28:24) **
Version for Linux x86/Motif (All rights reserved)
** This is freeware software (for non commercial use)

Type xnview -help, for more information
X Error of failed request: BadName (named color or font does not exist)
Major opcode of failed request: 45 (X_OpenFont)
Serial number of failed request: 544
Current serial number in output stream: 696

I never had problems before with xnview, but now I reinstalled completly my laptop and use different settings... So I don't know, is the problem related to modular X (xorg 7.0), missing font package (but which one), other settings ?

Is there any way to troubleshoot a bit more ? or have more verbose logging ?

Thanks in advance !
Tux Mago

Post by Tux Mago »

if someone has the same problem:

It's related to modular Xorg !

it can be solved by getting those fonts pkg:
- font-bh-lucidatypewriter-100dpi
- font-bh-lucidatypewriter-75dpi

(NB. I am running gentoo, so the emerge of those packages was enough, if you are using an other distro you may have to do a few more things, check the gentoo ebuild for what to do)...
Tux Mago

Post by Tux Mago »

just a strange bug (feature ?!? :) now ...

all the pictures have transparency (even the thumbnails), I see everything below (terminals, browsers, desktop background)... hopefully it's transparency, so I still see the pictures too... (anyway I think that I'll stick to gqview for the moment, it's not as great as xnview, but at least it works).

NB. this is probably related to XGL/Compiz...