Slow GIF playback?

Moderators: cday, XnTriq, helmut, xnview, Dreamer

Post Reply
Christmas5
Posts: 4
Joined: Tue Jun 11, 2019 12:30 am

Slow GIF playback?

Post by Christmas5 » Tue Jun 11, 2019 1:17 am

Recently I noticed that gifs seem to play a bit "slower" in xnviewmp. After comparing it to both IE and firefox, I concluded that xnviewmp does in fact play gifs a bit slower than browsers, which is quite irritating as sometimes it's very visible.

I wanted to ask if this is intentional and if there is something I can do about this, like changing the settings.

User avatar
xnview
Author of XnView
Posts: 31352
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Slow GIF playback?

Post by xnview » Tue Jun 11, 2019 8:19 am

could you post a gif sample?
Pierre.

Christmas5
Posts: 4
Joined: Tue Jun 11, 2019 12:30 am

Re: Slow GIF playback?

Post by Christmas5 » Tue Jun 11, 2019 1:26 pm

Sure, I tried adding it as an attachment.

Play the gif in xnviewmp and an internet browser at the same time. Place the windows next to each other and you should be able to notice that the gif plays smoother/faster in the browser.
example.gif

User avatar
xnview
Author of XnView
Posts: 31352
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Slow GIF playback?

Post by xnview » Thu Jun 20, 2019 9:03 am

:bugconfirmed: Thanks to your detailed description I can reproduce the problem.
Pierre.

Christmas5
Posts: 4
Joined: Tue Jun 11, 2019 12:30 am

Re: Slow GIF playback?

Post by Christmas5 » Fri Jul 05, 2019 11:58 am

Thank you for your work.

Post Reply