Migration of catagories from Windows Live Fotogallery to XnView MP

Moderators: cday, XnTriq, helmut, xnview, Dreamer

Post Reply
Oliva
Posts: 6
Joined: Sun Feb 24, 2019 5:00 pm

Migration of catagories from Windows Live Fotogallery to XnView MP

Post by Oliva » Sun Feb 24, 2019 6:49 pm

I am migrating about 13'000y pictures from an old Windows 7 to a new Windows 10 computer. Under Windows 7 I used Windows Live Photo Gallery 12 (Build 16.4.3528.331)to add my Pictures to about 100 categories, with four Levels of subcategories. Many times I use about four categories for the same photo.

As of march 2017 Windows Live Photo Gallery is not available any more from MS. I could get it still from other sources, but I would prefer a program, which is well maintained by someone. Therefore, I am looking for another program, which helps me to keep an overview of my Pictures.
XnView Mp is my favoured one of all the programs I looked at. I installed Version 0.93 32bits (Jan 31’2019) on my old computer in order to test it. It has all the features I need and even more. When I opened one folder with 4000 of my pictures it automatically read the categories from their metadata. Great!

But when I analysed the category tree, I found big differences between the version in Windows Live Photo Gallery 12 and the version in XnView Mp. I exported the categories file and found even more differences. I searched a lot in this forum. Particularly I followed all the hints in the contribution “How to keep categories in sync with IPTC” (<viewtopic.php?p=133396#p133396>).

My problem is visible in the following picture of the category tree of XnView Mp:

[attachment=0]image.png[/attachment]
I experimented a lot with the settings for Metadata of the Browser, specifically with the settings of the point “Read hierarchical keywords”. I even changed the codepage for encoding, since I thought that during parsing the Keywords, the separator is not recognized. Up to now I had no success and therefore I need some help.

Concrete questions:
How can it be, that during import the same(!) two pictures are
1. categorized once under the main category “Technik” and the subcategory “Abwasser”
2. and then again under the category “Technik/Abwasser”?
Why in addition to these two Pictures, four other pictures are only categorized under the category “Technik/Abwasser”?
(In the same Picture of the category hierarchy some other similar contradictions also show up.)

By the way: I NEVER exported DB Category to XMP Subject and IPTC keyword.

Could someone please help me? I need to have a solution in order to use XnView Mp with all the existing pictures.

Thank you very much for your help!
Attachments
image.png

User avatar
xnview
Author of XnView
Posts: 31737
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Migration of catagories from Windows Live Fotogallery to XnView MP

Post by xnview » Mon Mar 04, 2019 3:54 pm

is it possible to have a file sample?
Pierre.

Oliva
Posts: 6
Joined: Sun Feb 24, 2019 5:00 pm

Re: Migration of catagories from Windows Live Fotogallery to XnView MP

Post by Oliva » Sun Mar 10, 2019 9:22 pm

Hello Pierre,

sorry, that I did not respond earlier, but I was on holidays :(.

Today I tried again to update the catalog to get the categories, which are in the sidecar of the fotos. I was able to reproduce the effect, that I described with in my first post, using only two fotographs.

Attached you find these two fotos an also the file which I got through "Export categories file". I hope these files help to understand the problem.

Thank you very much for your help!

Gerhard
Attachments
Kategorien_XNViewMP_out_20190310.zip
(300 Bytes) Downloaded 14 times
20181019_182022(0) (480x640).jpg
20181019_182022(0) (480x640).jpg (316.53 KiB) Viewed 606 times
20160304_131234 (480x640).jpg
20160304_131234 (480x640).jpg (246.77 KiB) Viewed 606 times

User avatar
michel038
Posts: 354
Joined: Tue Sep 27, 2016 8:18 am
Location: France

Re: Migration of catagories from Windows Live Fotogallery to XnView MP

Post by michel038 » Mon Mar 11, 2019 1:23 pm

A first problem for develppers , in the first photo; Is a keyword missing ? or a keyword that should not appear ?
Attachments
oliva02.png
Last edited by michel038 on Mon Mar 11, 2019 2:06 pm, edited 1 time in total.

User avatar
michel038
Posts: 354
Joined: Tue Sep 27, 2016 8:18 am
Location: France

Re: Migration of catagories from Windows Live Fotogallery to XnView MP

Post by michel038 » Mon Mar 11, 2019 1:36 pm

Test #2
And same problem in the second picture ...

xmp-dc subject (1) seems not completely read.

Iptc keywords are not read as hierarchical keywords. OK normal.

( another test with "read hierarchical keywords" enabled = no change. ) (are iptc keyword really read ? ... see next test)
Attachments
oliva03.png
Last edited by michel038 on Mon Mar 11, 2019 2:23 pm, edited 3 times in total.

User avatar
michel038
Posts: 354
Joined: Tue Sep 27, 2016 8:18 am
Location: France

Re: Migration of catagories from Windows Live Fotogallery to XnView MP

Post by michel038 » Mon Mar 11, 2019 2:01 pm

# 3 Third test : read hierarchical iptc keywords (only on the second picture ):
- Deleted xmp-dc subject
- Enabled "read hierarchical keywords" , with "/"
- Could not delete multiple MicrosoftPhoto LastKeywords with xnviewmp.

Result :
-Child IPTC keywords are read :
Garage hinten : ok
Wand S : ok
Abwasser : ok (yes!)

... IPTC parent keywords are read, but not written in catalog. (?)

----------------------------------------------------------------------------------
# 4 Fourth test: read Iptc keywords without hierarchy
- Disabled "read hierarchical keywords"

Result: Three keywords read Ok
"Ort: Oliva/Garage hinten"
"Ort: Oliva/Wand S"
"Technik/Abwasser"

Bud two child keywords found that should not be here ?
Garage hinten
Wand S
(is it the same problem than test #2 ?)

User avatar
xnview
Author of XnView
Posts: 31737
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Migration of catagories from Windows Live Fotogallery to XnView MP

Post by xnview » Mon Mar 11, 2019 3:34 pm

ok, the problem with XMP in these files is that subject use hierarchical keyword.
"Ort: Oliva/Garage hinten" should be "Garage hinten", i'll fix for Fotogallery
Pierre.

Oliva
Posts: 6
Joined: Sun Feb 24, 2019 5:00 pm

Re: Migration of catagories from Windows Live Fotogallery to XnView MP

Post by Oliva » Mon Mar 11, 2019 8:35 pm

Thank you very much to all of you! If I can help with testing, let me know.

Gerhard

Oliva
Posts: 6
Joined: Sun Feb 24, 2019 5:00 pm

Re: Migration of catagories from Windows Live Fotogallery to XnView MP

Post by Oliva » Mon Jun 03, 2019 5:23 pm

Hallo Pierre,

I think my problem is not your most important one. Therefore, only once in a while I checked for an Update of XNView MP 0.93 in the program itself. Always there was the message "XNView MP is currently up to date". Only yesterday I noticed by searching directly on your Webpage, that there is the Version 0.93.1 of 08.03.2019.

I installed and tested the new version with the same two files I sent you before. The result is also the same as before. I do not know why. I noticed, too, that the settings on the page Settings / Browser / Metadata do not influence the result. I thought, that the result must change at least, if I use as separator ":" (as in "Ort: Oliva/Garage hinten") instead of "/", but the result was the same. This test I did not do with the old version.

I really would be glad to help in further testing by constructing examples with a given hierarchy of Keywords!

All the best, Gerhard

User avatar
xnview
Author of XnView
Posts: 31737
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Migration of catagories from Windows Live Fotogallery to XnView MP

Post by xnview » Tue Sep 17, 2019 10:24 am

This problem is supposed to be fixed in XnView MP 0.94. Please check and confirm the bug fix here.
Pierre.

Oliva
Posts: 6
Joined: Sun Feb 24, 2019 5:00 pm

Re: Migration of catagories from Windows Live Fotogallery to XnView MP

Post by Oliva » Mon Sep 30, 2019 6:54 pm

Hello Pierre,

thank you for the notice and the work you invested. Sorry, that I respond only today. I was on a longer hike in the mountains.

I tested the 0.94 beta 2 version with the two pictures I sent you earlier. It worked fine.

However, I am sorry to tell you, that the problem is not resolved totally. When I tested the program with my 13000 pictures I found out, that something goes still wrong, when a picture is assigned to a category more than one level down from the top category. In this case the program builds up the category tree in the right manner. However, it assigns a picture both to the right category in the tree, but also to a new category outside the tree, which begins with the second level of the category and goes down to the very last to which this picture ist assigned. Attached you will find a single picture which shoes that effect clearly.

Another effect during an update of the catalogue is not clear to me. The result is not dependent on the fact, if the box "Automatically apply parent keywords .." is ticked or not. The consequence is the pictures never are assigned to the parent keywords. This clearly visible if you add up the number of pictures in subcategories. It is always bigger then the number of picture in the parent category.

I hope these hints reach you in time and helps you to make your great program still better!

Best regards, Gerhard
Attachments
100_1564.JPG

User avatar
xnview
Author of XnView
Posts: 31737
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Migration of catagories from Windows Live Fotogallery to XnView MP

Post by xnview » Tue Oct 01, 2019 6:20 am

Oliva wrote:
Mon Sep 30, 2019 6:54 pm
However, I am sorry to tell you, that the problem is not resolved totally. When I tested the program with my 13000 pictures I found out, that something goes still wrong, when a picture is assigned to a category more than one level down from the top category. In this case the program builds up the category tree in the right manner. However, it assigns a picture both to the right category in the tree, but also to a new category outside the tree, which begins with the second level of the category and goes down to the very last to which this picture ist assigned. Attached you will find a single picture which shoes that effect clearly.
Ok, right, will be fixed
Another effect during an update of the catalogue is not clear to me. The result is not dependent on the fact, if the box "Automatically apply parent keywords .." is ticked or not. The consequence is the pictures never are assigned to the parent keywords. This clearly visible if you add up the number of pictures in subcategories. It is always bigger then the number of picture in the parent category.
This setting is only when you click on a category, not the import
Pierre.

Oliva
Posts: 6
Joined: Sun Feb 24, 2019 5:00 pm

Re: Migration of catagories from Windows Live Fotogallery to XnView MP

Post by Oliva » Tue Oct 01, 2019 9:17 pm

Thank you Pierre, for your fast reply! Let me know, when I can help with testing.

Gerhard

Post Reply