0.87 / Win 10: "Open with" path parsing

Moderators: cday, XnTriq, helmut, xnview, Dreamer

User avatar
dergilbwillspam
Posts: 13
Joined: Sat Nov 10, 2007 8:46 pm

0.87 / Win 10: "Open with" path parsing

Postby dergilbwillspam » Fri Oct 27, 2017 1:59 pm

XnView MP: Version 0.87 64bits (Sep 7 2017)
OS: Windows 10 Pro FCU 64bit

"Open with" fails if path contains percent sign followed by number.

Effect: Target program doesn't open file.

To reproduce:

1. Have a path like d:\%1\test.jpg
2. Have a program like MSPaint or Paint.NET configured in "Open with" in XnView
3. Try to open the file in target program with "Open with"

Actual behavior (bug): Target program doesn't open the file because path is not parsed correctly. :bug:

Expected behavior: Target program opens the file

User avatar
xnview
Author of XnView
Posts: 28394
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: 0.87 / Win 10: "Open with" path parsing

Postby xnview » Sun Oct 29, 2017 2:40 pm

:bugconfirmed: Thanks to your detailed description I can reproduce the problem.
Pierre.

User avatar
xnview
Author of XnView
Posts: 28394
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: 0.87 / Win 10: "Open with" path parsing

Postby xnview » Fri Nov 03, 2017 1:04 pm

This problem is supposed to be fixed in XnView MP 0.88. Please check and confirm the bug fix here.
Pierre.

User avatar
dergilbwillspam
Posts: 13
Joined: Sat Nov 10, 2007 8:46 pm

Re: 0.87 / Win 10: "Open with" path parsing

Postby dergilbwillspam » Tue Nov 14, 2017 1:55 am

This problem is supposed to be fixed in XnView MP 0.88. Please check and confirm the bug fix here.


Clicking the programs works now, but the "Open with" shortcuts (alt + number) still do not (same error as before: File not found.) :bug:

Sorry for not being able to respond sooner.

User avatar
xnview
Author of XnView
Posts: 28394
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: 0.87 / Win 10: "Open with" path parsing

Postby xnview » Wed Nov 15, 2017 1:43 pm

dergilbwillspam wrote:Clicking the programs works now, but the "Open with" shortcuts (alt + number) still do not (same error as before: File not found.) :bug:

No problem with shortcut in browser mode, but can't be opened in edit mode
Pierre.

User avatar
dergilbwillspam
Posts: 13
Joined: Sat Nov 10, 2007 8:46 pm

Re: 0.87 / Win 10: "Open with" path parsing

Postby dergilbwillspam » Wed Nov 15, 2017 4:08 pm

No problem with shortcut in browser mode, but can't be opened in edit mode


I didn't notice this, but you're right.


Return to “0.89 Testing – Retest”

Who is online

Users browsing this forum: No registered users and 2 guests