0.94b2: Offset dialog: Various bugs

Reported bugs that have been closed and/or resolved

Moderators: XnTriq, xnview, Dreamer

Post Reply
User avatar
helmut
Posts: 8174
Joined: Sun Oct 12, 2003 6:47 pm
Location: Frankfurt, Germany

0.94b2: Offset dialog: Various bugs

Post by helmut » Thu Sep 26, 2019 7:59 pm

I've tried out the new feature "Image > Offset". Offset function is supposed to add an user-defined offset to the image and thus shift it around within it's canvas.

From what I can see there are various bugs in beta2:

:bug: Repeat edge pixels and Offset 0,0
When setting offset to 0,0 (=no offset) and checking "Repeat edge pixels" the whole image will have one colour (wrong).
Expected: Image should be displayed without any change and offset.

:bug: Repeat edge pixels: Not repeated properly with horizontal offset =0
The edge pixels aren't repeated properly. To reproduce:
1. Check "Repeat edge pixels"
2. Set horizontal offset = 0
3. Move the image vertically by playing around with the vertical offset.
--> You will see that the edge pixels are repeated but the larger the vertical offset the less edge pixels are repeated (instead the fixed colour is used).

:bug: Wrap around: Doesn't wrap properly
When checking "Wrap around" and using horizontal offset = 0 and vertical offset ~ minus 50% of the image height, the image isn't wrapped properly. Instead, parts of the image can be seen twice. Please note that wrapping works fine when using a vertical offset which is downwords (positive).

:bug: Mismatch in coordinate system
This bug has been mentioned in the User design post. XnView's coordinate system starts in the bottom-left corner with 0,0 and the more you move to the left/up, the higher the positive coordinates are (you can try this by opening an image and watching the coordinates of the mouse cursor in the status bar.). In the offset dialog, down has positive values and up has negative values which is just the opposite of XnView's coordinate system.

User avatar
xnview
Author of XnView
Posts: 32077
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: 0.94b2: Offset dialog: Various bugs

Post by xnview » Fri Sep 27, 2019 9:17 am

helmut wrote:
Thu Sep 26, 2019 7:59 pm
:bug: Repeat edge pixels and Offset 0,0
When setting offset to 0,0 (=no offset) and checking "Repeat edge pixels" the whole image will have one colour (wrong).
Expected: Image should be displayed without any change and offset.
right
:bug: Repeat edge pixels: Not repeated properly with horizontal offset =0
The edge pixels aren't repeated properly. To reproduce:
1. Check "Repeat edge pixels"
2. Set horizontal offset = 0
3. Move the image vertically by playing around with the vertical offset.
--> You will see that the edge pixels are repeated but the larger the vertical offset the less edge pixels are repeated (instead the fixed colour is used).
Right
:bug: Wrap around: Doesn't wrap properly
When checking "Wrap around" and using horizontal offset = 0 and vertical offset ~ minus 50% of the image height, the image isn't wrapped properly. Instead, parts of the image can be seen twice. Please note that wrapping works fine when using a vertical offset which is downwords (positive).
Right
:bug: Mismatch in coordinate system
This bug has been mentioned in the User design post. XnView's coordinate system starts in the bottom-left corner with 0,0 and the more you move to the left/up, the higher the positive coordinates are (you can try this by opening an image and watching the coordinates of the mouse cursor in the status bar.). In the offset dialog, down has positive values and up has negative values which is just the opposite of XnView's coordinate system.
Right
Pierre.

User avatar
helmut
Posts: 8174
Joined: Sun Oct 12, 2003 6:47 pm
Location: Frankfurt, Germany

Re: 0.94b2: Offset dialog: Various bugs

Post by helmut » Thu Oct 17, 2019 6:22 pm

All issues above are fixed in beta 3. Thank you, Pierre!

Post Reply