0.85b1: Filter selection doesn't change when reset with icon

Reported bugs that have been closed and/or resolved

Moderators: XnTriq, xnview, Dreamer

Post Reply
vertigo
Posts: 115
Joined: Wed Feb 15, 2017 3:49 pm

0.85b1: Filter selection doesn't change when reset with icon

Post by vertigo » Sat Mar 18, 2017 4:49 pm

XnView: MP 0.85b1 x64
OS: Windows 7 - 64 bit

If you select any filter (videos, tagged, etc), then click the filter icon (not the arrow for the dropdown), it resets the filter and all files show again, but if you now click the dropdown arrow, you'll see it still shows the filter you selected as being active. It switches back to having custom selected once you change folders.
Effect: Confusing interface

To reproduce:
1. Open browser and select a filter. Note that the displayed files shrinks, possibly to zero, due to the filter being applied.
2. Click the filter icon in the toolbar, and note that all files are displayed again due to the 'Custom' filter being applied.
3. Click the filter dropdown arrow and note that the filter selected in step 1 still shows as active.
4. Change to another folder and click the filter dropdown arrow again. Note that now the 'Custom' filter shows as selected.
Actual behaviour (bug): The selected filter isn't updated until after changing folders.

Expected behaviour: The selected filter should update as soon as it is changed (upon pressing the filter icon)

User avatar
helmut
Posts: 8153
Joined: Sun Oct 12, 2003 6:47 pm
Location: Frankfurt, Germany

Re: 0.85b1: Filter selection doesn't change when reset with

Post by helmut » Sat Mar 18, 2017 7:30 pm

Reproduced. This problem was introduced in 0.85 beta 1; it works fine in 0.84.

User avatar
xnview
Author of XnView
Posts: 31264
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: 0.85b1: Filter selection doesn't change when reset with

Post by xnview » Thu Mar 23, 2017 10:03 am

This problem is supposed to be fixed in XnView MP 0.85 beta 2. Please check and confirm the bug fix here.
Pierre.

vertigo
Posts: 115
Joined: Wed Feb 15, 2017 3:49 pm

Re: 0.85b1: Filter selection doesn't change when reset with

Post by vertigo » Thu Mar 23, 2017 6:43 pm

Confirmed fixed.

User avatar
helmut
Posts: 8153
Joined: Sun Oct 12, 2003 6:47 pm
Location: Frankfurt, Germany

Re: 0.85b1: Filter selection doesn't change when reset with

Post by helmut » Thu Mar 23, 2017 7:04 pm

vertigo wrote:Confirmed fixed.
Good. Thank you for checking, vertigo!

Post Reply