Message "Please restart" after changing theme

Reported bugs that have been closed and/or resolved

Moderators: XnTriq, xnview, Dreamer

Post Reply
User avatar
helmut
Posts: 8153
Joined: Sun Oct 12, 2003 6:47 pm
Location: Frankfurt, Germany

Message "Please restart" after changing theme

Post by helmut » Sat Oct 15, 2016 9:18 am

Subject: 0.83: Changing theme doesn't update XnView

When switching themes, XnView MP is not always updated.

To reproduce:
1. When switching from Fusion them to Fusion dark, XnView MP is updated. (o.k.)
2. When switching back from Fusion dark to Fusion, XnView MP is not updated. :bug:

User avatar
xnview
Author of XnView
Posts: 31347
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: 0.83: Changing theme doesn't update XnView

Post by xnview » Sun Oct 16, 2016 5:22 pm

you need to restart to update theme...
Pierre.

User avatar
helmut
Posts: 8153
Joined: Sun Oct 12, 2003 6:47 pm
Location: Frankfurt, Germany

Re: 0.83: Changing theme doesn't update XnView

Post by helmut » Tue Oct 18, 2016 6:06 pm

xnview wrote:you need to restart to update theme...
O.k., I didn't know because most colours change immediately. Perhaps a message box: "Please restart XnView to apply the new theme." would be good (just like when changing the setting for the on-screen language).

:arrow: Suggestion

vertigo
Posts: 115
Joined: Wed Feb 15, 2017 3:49 pm

0.84: Default theme doesn't apply until restarting program

Post by vertigo » Tue Feb 21, 2017 12:53 am

XnView: MP 0.84 x64
OS: Windows 7 - 64 bit

When switching themes, all themes but default take effect immediately, but switching to default requires a restart of the program to take effect.

Effect: Requires restart to switch (back) to default theme, making switching themes somewhat of a pain

To reproduce:
1. Select any theme, then select any other
2. All themes except default will take effect as soon as selected
3. When selecting default theme, nothing happens until program is restarted, at which point it will take effect

Actual behaviour (bug): Default theme doesn't activate properly

Expected behaviour: Should switch to default theme immediately after selecting it

User avatar
helmut
Posts: 8153
Joined: Sun Oct 12, 2003 6:47 pm
Location: Frankfurt, Germany

Re: 0.84: Default theme doesn't apply until restarting progr

Post by helmut » Tue Feb 21, 2017 4:04 pm

Thanks for reporting, vertigo. I've posted a suggestion before and merged it with this bug report.

(It's more a bug than a suggestion because the lack of the message box causes quite some confusion.)

:arrow: Reproduced

User avatar
xnview
Author of XnView
Posts: 31347
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Message "Please restart" after changing theme

Post by xnview » Tue Feb 28, 2017 3:29 pm

O.k., thank you, I can also reproduce the problem. Issue 1136 is fixed in next version.
Pierre.

User avatar
xnview
Author of XnView
Posts: 31347
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Message "Please restart" after changing theme

Post by xnview » Thu Mar 16, 2017 8:51 am

This problem is supposed to be fixed in XnView MP 0.85 beta 1. Please check and confirm the bug fix here.
Pierre.

vertigo
Posts: 115
Joined: Wed Feb 15, 2017 3:49 pm

Re: Message "Please restart" after changing theme

Post by vertigo » Thu Mar 16, 2017 9:46 am

Confirmed fixed.

Post Reply