Ubuntu 16.10 yakketi Yak: XnView doesn't launch

Reported bugs that have been closed and/or resolved

Moderators: XnTriq, xnview, Dreamer

Post Reply
Posts: 3
Joined: Fri Oct 14, 2016 3:40 pm

Ubuntu 16.10 yakketi Yak: XnView doesn't launch

Post by krakatoa_pb » Fri Oct 14, 2016 3:52 pm


The XnViewMP application seems to be not working with the new Ubuntu distrib (16.10 yakketi Yak).

Until 16.04 I just had to install libgstreamer-plugins-base0.10-0 and libgstreamer0.10-0 with apt-get. Now, with 16.10 XnView say 'libgstapp-0.10.so.0: cannot open shared object file: No such file or directory'. Any solution?

libgstreamer is now in version 1.0 in Ubuntu 16.10


User avatar
Author of XnView
Posts: 31737
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: Linux: Ubuntu 16.10 yakketi Yak and XnViewMP

Post by xnview » Sat Oct 15, 2016 9:07 am

is it possible to install gstreamer0.10?

Posts: 3
Joined: Fri Oct 14, 2016 3:40 pm

Re: Linux: Ubuntu 16.10 yakketi Yak and XnViewMP

Post by krakatoa_pb » Sat Oct 15, 2016 9:40 am

xnview wrote:is it possible to install gstreamer0.10?
I think yes...

Just downloaded and installed 16.04 packets. XnView is running perfectly (but not yet trying a lot of functions).

Code: Select all

wget http://fr.archive.ubuntu.com/ubuntu/pool/main/g/gst-plugins-base0.10/libgstreamer-plugins-base0.10-0_0.10.36-1_amd64.deb
wget http://fr.archive.ubuntu.com/ubuntu/pool/universe/g/gstreamer0.10/libgstreamer0.10-0_0.10.36-1.5ubuntu1_amd64.deb
dpkg -i libgstreamer*.deb

User avatar
Posts: 9
Joined: Mon Oct 17, 2016 12:11 pm

Re: Linux: Ubuntu 16.10 yakketi Yak and XnViewMP

Post by xnviocumo » Mon Oct 17, 2016 1:39 pm

Same problem in my Xubuntu 16.10 Yakketi Yak:

Code: Select all

/opt/XnView/XnView: error while loading shared libraries: libgstapp-0.10.so.0: cannot open shared object file: No such file or directory.
The missing package libgstreamer-plugins-base0.10-0 in Yakketi has these dependencies:

Code: Select all

Depends: libc6 (>= 2.14), libglib2.0-0 (>= 2.37.3), libgstreamer0.10-0 (>= 0.10.36), liborc-0.4-0 (>=
         1:0.4.20), zlib1g (>= 1:1.1.4), iso-codes
PreDepends: multiarch-support
... and these conflicts:

Code: Select all

Conflicts: gstreamer0.10-pulseaudio (< 0.10.16-4), totem-gstreamer (<= 2.17.92-0ubuntu1),
           gstreamer0.10-pulseaudio:i386 (< 0.10.16-4)
Although the dependencies version numbers are "same or greater than...", I am always reluctant by principle to install older libraries and possibly ending up in something getting broken later that might not be easy to figure the cause. Also, it's easy to forget, after few months, that one has installed such "lonely" library that is not supported any longer.

Is it somehow possible that XnViewMP gets this fixed so it uses the libgstapp-1.0.so.0 (from libgstreamer-plugins-base1.0-0) instead the old 0.1 version? As far as Ubuntu (sorry, I haven't checked other distros, please guys could anyone expand this to other distros?), the libgstreamer-plugins-base1.0-0 package is available since Ubuntu 14.04 Trusty Tahr, (so, since at least two and a half years ago) as you can confirm here:

http://packages.ubuntu.com/search?suite ... ibgstapp-1
http://packages.ubuntu.com/search?suite ... ibgstapp-1
http://packages.ubuntu.com/search?suite ... ibgstapp-1

Of course, there are people using older versions than 14.04, it's also true that in such cases many other things are broken in those systems, tremendously much more critical than XnViewMP. However, Ubuntu is not the only Linux distro!!, and I hate those who think that everyone should update to the newest thing. So: if supporting older/different distros is strategic for XnView, may I suggest (don't kill me, it's just an idea!) some kind of "compromise", i.e. perhaps a XnViewMP release for "not bleeding edge" distros, using the older libgstapp 0.1 and another release using the 1.0 version?

Any other ideas ?
Contribution from other non Ubuntu distros?

Thanks a lot for this fantastic software!

Just to add, that my proposal of two versions is something that have been done successfully by other fantastic and highly reputed projects, such as the excellent Krita (krita.org), which also has limited resources, yet it manages to keep a hugely loyal crowd of users of pretty much any existing operating system. Currently, they are also using new packaging technologies, which might be of interest as well.

Posts: 1
Joined: Sat Oct 22, 2016 12:06 am

Re: Linux: Ubuntu 16.10 yakketi Yak and XnViewMP

Post by tdonnelly66 » Sat Oct 22, 2016 12:33 am

I appear to be having the same issue as xnviocumo. I'm running Ubuntu Mate 16.10 ("Yakkety Yak") as a result of an automated update this morning. I previously had been running XnViewMP on the previous version (Ubuntu Mate 16.04 LTS) with no issues.

But now, clicking on the XnViewMP icon in my main menu (under "Graphics") -- or, alternately, running the shell script directly -- causes XnViewMP to try and open at the bottom of my display, but never actually opens (the app appears to crash).

I uninstalled and reinstalled XnViewMP -- but the problem continued.

I confirmed that the 16.10 distribution included the gstreamer1.0 package and associated plugins and libraries.

Is this an issue of XnViewMP not supporting the current gstreamer libraries, or is it a different issue?

Could you please let us know how long you expect to fully diagnose the problem and fix it?

Many thanks as always. This is a great app. It would be a shame to be unable to use it on the latest Ubuntu distributions.

Posts: 1
Joined: Sat Oct 29, 2016 9:44 pm

Re: Linux: Ubuntu 16.10 yakketi Yak and XnViewMP

Post by xzo » Sat Oct 29, 2016 9:59 pm

Same issue on Xubuntu 16.10. Installs fine but program doesn't run. Will XnViewMP be fixed to support 16.10?

Edit: Adding the gstreamer0.10 packages worked for now (thanks krakatoa_pb). However, I don't see any videos thumbnails and videos don't play despite "Visible", "Show as thumbnail" and "Show in preview" options turned on. I tried installing the gstreamer0.10 ffmpeg plugin but that didn't help. To be honest, I'm not sure if I had it working before on Linux Mint 18 and I rarely used it when I was still on Windows. It's still a great program even without video functionality.

Posts: 5
Joined: Sat Dec 10, 2016 7:32 pm

Re: Linux: Ubuntu 16.10 yakketi Yak and XnViewMP

Post by jloveless » Sat Dec 10, 2016 7:46 pm

I installed the libgstreamer0.10-0_0.10.36-1.5ubuntu1_amd64.deb following the instructions posted by by krakatoa_pb » Sat Oct 15, 2016 (see that post). You need to use sudo on the last command but it worked fine and now XNViewMP is working again. Phew.

Roger Davis
Posts: 5
Joined: Fri Dec 23, 2016 4:06 am

Re: Linux: Ubuntu 16.10 yakketi Yak and XnViewMP

Post by Roger Davis » Fri Dec 23, 2016 4:19 am

Jloveless - Do the videos also work, or ONLY the stills ?

User avatar
Posts: 8171
Joined: Sun Oct 12, 2003 6:47 pm
Location: Frankfurt, Germany

Re: Ubuntu 16.10 yakketi Yak: XnView doesn't launch

Post by helmut » Fri Mar 03, 2017 3:19 pm

Problem with launching is resolved.

:arrow: Closed

Post Reply