"Not responding" when switch to browse mode depends on number of child folders in grandparent folder

Bugs which are supposed to be fixed in the next test version (not available yet)

Moderators: XnTriq, xnview, Dreamer

gm649
Posts: 48
Joined: Thu Sep 12, 2019 10:42 am

"Not responding" when switch to browse mode depends on number of child folders in grandparent folder

Post by gm649 »

Problem : "Not responding" when switch to browse mode depends on number of child folders in grandparent folder

for example , i'm viewing the image which path is E:\ParentFolder\ChildFolder\img.jpg
then i double click to switch to browse mode ( i want to sort images)
it seems that the time loading browse mode depends on the number of child folders of "grand parent folders" , in this case ,the "grand parent folders" is "E:\ParentFolder\"
if "ParentFolder" has many folders in it (about 1000) , it cause "not responding" issue in view child folder , although i only want to view only the "ChildFolder" not view 1000 folders in "ParentFolder"

if "ParentFolder" not has many folders in it, it works fine

Im using xnview latest version 0.98.4 on windows 10
update: bug also exist in latest version 0.99.0
User avatar
xnview
Author of XnView
Posts: 36286
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: "Not responding" when switch to browse mode depends on number of child folders in grandparent folder

Post by xnview »

Strange, if you go in E:\ParentFolder\ChildFolder, there is no check of ParentFolder
If you start XnView as browser in this folder, same delay?
Pierre.
gm649
Posts: 48
Joined: Thu Sep 12, 2019 10:42 am

Re: "Not responding" when switch to browse mode depends on number of child folders in grandparent folder

Post by gm649 »

xnview wrote: Thu Sep 23, 2021 9:36 am Strange, if you go in E:\ParentFolder\ChildFolder, there is no check of ParentFolder
If you start XnView as browser in this folder, same delay?
Yes it seems to be the same,i try browse E:\ParentFolder and it cause long not responding , i sent you the clips that describe the bug in private message, please check it
Thank you
User avatar
xnview
Author of XnView
Posts: 36286
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: "Not responding" when switch to browse mode depends on number of child folders in grandparent folder

Post by xnview »

:bugconfirmed: Thanks to your detailed description I can reproduce the problem.
Pierre.