0.98.4: Parent category not applied on Enter

Bugs which are supposed to be fixed in the next test version (not available yet)

Moderators: XnTriq, xnview, Dreamer

Post Reply
solowing
Posts: 3
Joined: Sat Jun 05, 2021 11:04 am

0.98.4: Parent category not applied on Enter

Post by solowing »

Subject: 0.85: <short bug title>

XnView: MP 0.98.4 - 64 bit
OS: Windows 10

In Settings>Metadata>IPTC & XMP, there's a setting called "Automatically apply parent keywords." When this setting is applied, if you click a subcategory (btw, I think the mixed usage of 'keyword' and 'category' in this program is a bit confusing), the parent category is applied. However, you can also apply a category by selecting an image, then searching for the category in the Categories Pane. When the result shows up in the dropdown box you can hit Enter on it to apply the category. In this case, however, parent categories are not automatically applied even if you have them set to. This means that the preference settings only works if you apply categories with the mouse.

Effect: Categories are more time-consuming to apply.

To reproduce:
1. Go to Settings>Metadata>IPTC & XMP
2. Enable "Automatically apply parent keywords."
3. Select an image.
4. Open the Categories Pane and use the quick-search to find a subcategory.
5. Hit Enter on the subcategory.
6. The subcategory is applied, but the parent category is not.

Expected behaviour: The parent category should also be applied.
User avatar
xnview
Author of XnView
Posts: 35489
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: 0.98.4: Parent category not applied on Enter

Post by xnview »

:bugconfirmed: Thanks to your detailed description I can reproduce the problem.
Pierre.
solowing
Posts: 3
Joined: Sat Jun 05, 2021 11:04 am

Re: 0.98.4: Parent category not applied on Enter

Post by solowing »

Thank you!
Post Reply