0.98.3: Program not showing people's regions

Bugs which are supposed to be fixed in the next test version (not available yet)

Moderators: XnTriq, xnview, Dreamer

Post Reply
soyelrafa
Posts: 7
Joined: Mon May 31, 2021 4:43 pm

0.98.3: Program not showing people's regions

Post by soyelrafa »

XnView: MP 0.98.3 64bits (May 6 2021)
Libformat: 7.75
OS: Windows 64bit

Hello, I have enabled on View the option of "Show people's region, but it's not showing anything.

Here are the properties of the file:
People Regions.png
People Regions.png (18.88 KiB) Viewed 732 times
Effect: It's not showing people's region faces, even enabling its option.

To reproduce:
1. Set a face with Picasa (for example).
2. Open the photo with the face with XNView MP.
3. Enable Show people's region on View menu.

Actual behaviour (bug): Not showing people's regions :bug:

Expected behaviour: The program should show rectangles for each face.

Regards and thanks.

EDIT: Updating to the last version (0.98.3) (oddly the program itself updater tell me that it was up to date, but in the website I found there was a new version) didn't solve the issue.
User avatar
xnview
Author of XnView
Posts: 35490
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: 0.98.3: Program not showing people's regions

Post by xnview »

could you post a file? I can't reproduce
Pierre.
soyelrafa
Posts: 7
Joined: Mon May 31, 2021 4:43 pm

Re: 0.98.3: Program not showing people's regions

Post by soyelrafa »

xnview wrote: Mon May 31, 2021 5:55 pm could you post a file? I can't reproduce
Sure, here it is, as attachment.

I added a face named "Test"
Attachments
IMG-20210511-WA0000.jpg
User avatar
xnview
Author of XnView
Posts: 35490
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: 0.98.3: Program not showing people's regions

Post by xnview »

you have not that?
Clipboard-1.jpg
Clipboard-1.jpg (40.48 KiB) Viewed 677 times
Pierre.
soyelrafa
Posts: 7
Joined: Mon May 31, 2021 4:43 pm

Re: 0.98.3: Program not showing people's regions

Post by soyelrafa »

xnview wrote: Tue Jun 01, 2021 10:27 am you have not that? Clipboard-1.jpg
Nope, I don't have it, maybe I have to enable something else?
Sin título.png
User avatar
xnview
Author of XnView
Posts: 35490
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: 0.98.3: Program not showing people's regions

Post by xnview »

do you have Settings>Metadata>Import XMP face tag?
Do you use Catalog?
Pierre.
soyelrafa
Posts: 7
Joined: Mon May 31, 2021 4:43 pm

Re: 0.98.3: Program not showing people's regions

Post by soyelrafa »

xnview wrote: Wed Jun 02, 2021 7:49 am do you have Settings>Metadata>Import XMP face tag?
Do you use Catalog?
Yes, I have enabled that option. Also, I added my photos folder on Catalog, but still not appearing.

However, I find that some photos did indeed show faces. And there is a difference in the properties.

The photos that are working show the properties of the face as "MWG", while the photos that aren't working show them as "mwg-rs".
User avatar
xnview
Author of XnView
Posts: 35490
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: 0.98.3: Program not showing people's regions

Post by xnview »

soyelrafa wrote: Wed Jun 02, 2021 10:43 am The photos that are working show the properties of the face as "MWG", while the photos that aren't working show them as "mwg-rs".
could you send me one sample too?
Pierre.
soyelrafa
Posts: 7
Joined: Mon May 31, 2021 4:43 pm

Re: 0.98.3: Program not showing people's regions

Post by soyelrafa »

Now it seems to be solved, after restarting the program several times now it seems that it gets the catalog update or something and it's showing the faces.

BTW, It's the program (XNView) which changes "mwg-rs" to "MWG", since I didn't modify the photos that weren't working before and has "mwg-rs" and now they have "MWG".
User avatar
xnview
Author of XnView
Posts: 35490
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: 0.98.3: Program not showing people's regions

Post by xnview »

soyelrafa wrote: Wed Jun 02, 2021 12:41 pm BTW, It's the program (XNView) which changes "mwg-rs" to "MWG", since I didn't modify the photos that weren't working before and has "mwg-rs" and now they have "MWG".
Where?
Pierre.
soyelrafa
Posts: 7
Joined: Mon May 31, 2021 4:43 pm

Re: 0.98.3: Program not showing people's regions

Post by soyelrafa »

xnview wrote: Wed Jun 02, 2021 12:42 pm
soyelrafa wrote: Wed Jun 02, 2021 12:41 pm BTW, It's the program (XNView) which changes "mwg-rs" to "MWG", since I didn't modify the photos that weren't working before and has "mwg-rs" and now they have "MWG".
Where?
On their properties.

This is a photo that is not working:
Not Working photo.png
Not Working photo.png (19.33 KiB) Viewed 613 times
And this is a photo that is working:
Working photo.png
Working photo.png (18.99 KiB) Viewed 613 times

It's not the same photo, but I can assure you that I checked several photos and before they have the properties like in the first case, and now they are working and have like in the second case.
User avatar
xnview
Author of XnView
Posts: 35490
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: 0.98.3: Program not showing people's regions

Post by xnview »

:bugconfirmed: Thanks to your detailed description I can reproduce the problem.
Pierre.
soyelrafa
Posts: 7
Joined: Mon May 31, 2021 4:43 pm

Re: 0.98.3: Program not showing people's regions

Post by soyelrafa »

xnview wrote: Thu Jun 03, 2021 6:22 am :bugconfirmed: Thanks to your detailed description I can reproduce the problem.
Perfect, thanks you!!

Regards.
Post Reply