0.84 and 0.85b2 - list details vanish on restart

Bugs which have been reproduced by a second user or the developer

Moderator: Dreamer

CameronD
Posts: 269
Joined: Wed Aug 01, 2007 1:28 pm
Location: Australia

0.84 and 0.85b2 - list details vanish on restart

Postby CameronD » Sat Mar 25, 2017 5:48 am

XnView MP v: 0.84 and 0.85 beta2 (23-Mar-2017) (both 64-bit)
OS: Windows 7 Pro, x64

Description:
sorting details by metadata causes details list to blank all blob metadata when program restarts.

To Reproduce:
  • put browser in details mode, showing a range of metadata
  • click on a metadata column to sort by that value (I have tried with Rating, Caption, ShutterSpeed and Exif:Date Taken; all show the same bug)
  • exit the program
  • restart the program

Expected:
The program starts up with the same list as was showing before the program was closed

Actual Result:
Most metadata fields are blank. The list is sometimes sorted in the wrong order, depending on column chosen.
Pressing refresh, F5, or cd to another folder and back will fix the issue.

User avatar
m.Th.
XnThusiast
Posts: 1366
Joined: Wed Aug 16, 2006 6:31 am
Contact:

Re: 0.84 ans 0.85b2 - list details vanish on restart

Postby m.Th. » Sat Mar 25, 2017 8:26 am

Works for me... - same specs as you.
(Sorted by ShutterSpeed.)
m. Th.

The Ascetic Experience - The best photos and texts from Holy Mountain (Athos)

- Dark Themed XnViewMP 0.86 64bit & XnView 2.00 x64 on Win7 x64 -

CameronD
Posts: 269
Joined: Wed Aug 01, 2007 1:28 pm
Location: Australia

Re: 0.84 ans 0.85b2 - list details vanish on restart

Postby CameronD » Sat Mar 25, 2017 1:27 pm

m.Th. wrote:Works for me... - same specs as you.
(Sorted by ShutterSpeed.)


Hmm, obviously depends on something else as well. :?

Not worth putting much effort into, as it's a simple enough step to make it display properly.

For one last test, try enabling all columns and retest.

In my case, the initial list appears sorted by name (wrong) and for a fraction of a second the metadata is there too (correct for the name-sorted list) - then the metadata disappears and the list remains in name-sorted order.

User avatar
m.Th.
XnThusiast
Posts: 1366
Joined: Wed Aug 16, 2006 6:31 am
Contact:

Re: 0.84 and 0.85b2 - list details vanish on restart

Postby m.Th. » Sat Mar 25, 2017 4:05 pm

For one last test, try enabling all columns and retest.


I had/have them enabled all by default. Sorry <big sheepish grin>

...try on another folders with another EXIF data - it works the same?
m. Th.

The Ascetic Experience - The best photos and texts from Holy Mountain (Athos)

- Dark Themed XnViewMP 0.86 64bit & XnView 2.00 x64 on Win7 x64 -

User avatar
helmut
Posts: 8116
Joined: Sun Oct 12, 2003 6:47 pm
Location: Frankfurt, Germany

Re: 0.84 and 0.85b2 - list details vanish on restart

Postby helmut » Sat Mar 25, 2017 5:58 pm

I've tried quite a bit but couldn't reproduce the problem you (CameronD) experience, either.

Is it "Details" view or "Thumbnails+Details" view?

CameronD
Posts: 269
Joined: Wed Aug 01, 2007 1:28 pm
Location: Australia

Re: 0.84 and 0.85b2 - list details vanish on restart

Postby CameronD » Sun Mar 26, 2017 9:16 am

helmut wrote:...Is it "Details" view or "Thumbnails+Details" view?

Details - one line per file- see screenshots.

I have 4 installations of xnviewMP, all 64-bit, each with their own ini file, db, etc
  • 0.84 dark theme (normal working version)
  • 0.84 test - default theme
  • 0.85 beta 1
  • 0.85 beta 2
All show the bug.

Even weirder, I just tried a laptop that has v0.81 installed. It also showed the bug, twice, and from then on I cannot reproduce on that machine. I was in the same folder all the time and no files or folders were changed.

The second time the bug occurred, I was sorting by caption and it only showed the first Exif:date value. Normally, on my desktop, the Exif:Date values are always shown.
I repeated the test using a local copy of the same folder (40 jpegs) on my desktop - fails every time.

Here is what the list looks like after I set it up to sort by caption, just before exiting the program.
Xnview-085b2-sorted-by-caption.png
list of images after sorting by caption, just before exiting XnViewMP


And here it what it looks like immediately after I restart XnViewMP
Xnview-085b2-sorted-by-caption+restart.png
The same list immediately after restarting XnViewMP.


If I sort by filename, file size, date created, date modified, then the metadata is displayed properly.

User avatar
Dreamer
XnThusiast
Posts: 4578
Joined: Sun Jul 25, 2004 9:08 pm
Location: Slovakia

Re: 0.84 and 0.85b2 - list details vanish on restart

Postby Dreamer » Sun Mar 26, 2017 12:13 pm

Confirmed in 0.84 and 0.85 b2.

Here the correct metadata blink for a moment first, then disappear.

I can always reproduce it in one folder, never in some others, and just once or sometimes in the others, without changing any option or clicking any object in MP.

Right now the metadata were loaded just partly.

zzScreenshot_03262017_135515.png
Dreamer

User avatar
xnview
Author of XnView
Posts: 27345
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: 0.84 and 0.85b2 - list details vanish on restart

Postby xnview » Thu Jun 15, 2017 8:39 am

Always the bug in 0.86?? i can't reproduce
Pierre.

CameronD
Posts: 269
Joined: Wed Aug 01, 2007 1:28 pm
Location: Australia

Re: 0.84 and 0.85b2 - list details vanish on restart

Postby CameronD » Mon Jun 19, 2017 9:08 am

Hello Pierre,
I can still reproduce on 0.86, x64 on Windows 7.
Sometimes!

I have done some experimenting and it seems to be reproducible under the following conditions.

I have a folder with 160 jpeg images. Select a number of files, more than 10 is needed - 14 or 15 seems to make it fairly reliable.
Add a caption, and "write all".
Cancel, and exit.

Restart XnviewMP and see the bug symptoms.

If I modify captions of maybe 20 files, but only a small number at a time, then I do not see the problem. Even two groups of 10 each was OK.

CameronD
Posts: 269
Joined: Wed Aug 01, 2007 1:28 pm
Location: Australia

Re: 0.84 and 0.85b2 - list details vanish on restart

Postby CameronD » Mon Jun 19, 2017 9:40 am

update: I started with a blank DB and stepped through the process, saving the db each stage.

The problem seems to be that when the large block of captions is written to, the IPTC/XMP data is updated in the file, but the metadata in the DB is not.

When I restart XnviewMP it scans the modified files and updates the DB, but does not update the display.

When I restart XnviewMP again the file and DB metadata are in sync so it just starts normally.

User avatar
xnview
Author of XnView
Posts: 27345
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: 0.84 and 0.85b2 - list details vanish on restart

Postby xnview » Mon Jun 19, 2017 2:00 pm

so it's always after an IPTC editing?
Pierre.

CameronD
Posts: 269
Joined: Wed Aug 01, 2007 1:28 pm
Location: Australia

Re: 0.84 and 0.85b2 - list details vanish on restart

Postby CameronD » Mon Jun 19, 2017 2:12 pm

xnview wrote:so it's always after an IPTC editing?

yes.

From looking at how the DB behaves, I guess it might also happen if other software changes metadata between stopping and restarting xnviewmp.


Return to “Reproduced”

Who is online

Users browsing this forum: No registered users and 1 guest