Delete action doesn't delete file?

Ask for help and post your question on how to use XnView MP.

Moderators: XnTriq, xnview

iiigoiii
Posts: 3
Joined: Tue Aug 26, 2014 6:25 am

Delete action doesn't delete file?

Postby iiigoiii » Tue Aug 26, 2014 6:59 am

Curious if this is a known bug - XnViewMP v0.68 for Mac OSX.

I choose a file in Browser view
Edit - Delete
Get a confirmation dialog "Are you sure to delete these 1 item(s)?"
Click on 'Yes'
Nothing happens. File stays present.

I double checked the permissions on the file via the command line: a+rwx. And, I can delete the file with the rm command.

(I did notice that for some reason, the file permissions were not originally all rwxrwxrwx , so I changed them via the command line and restarted XnViewMP. Wondering if there is a permissions cache within XnViewMP that is preventing the file from being deleted?)

Thanks....

User avatar
xnview
Author of XnView
Posts: 27670
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Delete action doesn't delete file?

Postby xnview » Wed Aug 27, 2014 1:48 pm

strange, another user has the same problem. But i can't reproduce it.
you are able to reproduce it each time?
Pierre.

iiigoiii
Posts: 3
Joined: Tue Aug 26, 2014 6:25 am

Re: Delete action doesn't delete file?

Postby iiigoiii » Thu Aug 28, 2014 11:17 pm

I can reproduce it every time on that particular directory. Is there a debug mode or something I can turn on to help you figure this out?

It's also happened on other directories of images in the past, this isn't the only time....

iiigoiii
Posts: 3
Joined: Tue Aug 26, 2014 6:25 am

Re: Delete action doesn't delete file?

Postby iiigoiii » Fri Aug 29, 2014 5:29 am

Just checked again on the permissions, and found something that might be of interest. Initially the permissions on the files in the folder were all rwxrwxrwx , as was the directory itself.

I tried doing a lossless jpg rotation on 2 of the files that can't be deleted. I was able to do it, meaning that I'm able to modify the files in some way. However, after doing the transform, the permissions on the files had been changed from rwxrwxrwx to rw-r--r-- . And, still unable to delete those files.

Don't know if that helps....

User avatar
xnview
Author of XnView
Posts: 27670
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Delete action doesn't delete file?

Postby xnview » Fri Aug 29, 2014 9:50 am

if you don't use lossless operation, no problem?
Pierre.

cossoft
Posts: 3
Joined: Fri Sep 26, 2014 10:37 pm

Re: Delete action doesn't delete file?

Postby cossoft » Fri Sep 26, 2014 11:15 pm

Hi Pierre.

I also have just discovered this problem. Grrr. Spent about 6 hours pruning years of holiday photos, just to find tonight that they are all still there. This is what seems to happen:-

Go to a folder of piccies.
After a little while all the thumbnails appear.
Select some for deletion.
Delete, answering Yes in the dialogue box.
Thumbnails disappear and you think that's that.

Now, leave the folder for another one.
Return to your previous folder and wait for the thumbnails to reappear (seems to take a while - thought these were cached?)
Your deleted thumbnails as well as the underlying files are all back! This isn't a one of; it's reproduceable.

Also, another strange thing (perhaps unrelated). When looking at the thumbnails, and you double click one to view it properly, it appears as expected but then there is a 15 second network traffic burst at approximately 4.5 MB/s. Reiterating, this is after the picture has completed rendering. That's a lot of traffic.

My environment:-
Ubuntu 14.04 LTS
XnViewMP, Version 0.68 (May 15 2014), Libformat version 6.58
The images folders are on a Samba share from another 14.04 LTS server.

Hope that someone can help as it's difficult to use this application for image management if you can't delete any...

cossoft
Posts: 3
Joined: Fri Sep 26, 2014 10:37 pm

Re: Delete action doesn't delete file?

Postby cossoft » Sat Sep 27, 2014 1:34 am

Follow up:-

I've done some more investigating, and found the following:-

The effect also extends to whole folders. Delete a folder, and it's back when you revisit the parent folder.

I can confirm user iiigoiii's behaviour with image rotation. Rotate the image (lossless), crop the image or apply Map /Negative and the changes are persisted. Still can't delete the file though.

If you delete images some other way ie. terminal window they get deleted as expected under linux. What then happens in XnViewMP is shown in the attached screen grab. Files CSC_4000.JPG and DSC_3686.JPG have been manually deleted via terminal commands, but still appear as files albeit without proper thumbnail piccies.

There is also some strange behaviour with the database maintenance section of the application. The file count listed in the Files column does not seem to change no matter what. Even (as in the case above) externally deleting files from the folder is not reflected in the file count. Clearing out the database and then rebuilding the thumbnails does not alter the file count. So in my example case, the dialogue was showing 311 files, when I'd deleted some and a general desktop file browser was indicating 308.

Turning off the thumbnail caching seems to make no difference to the file count /deletion problem.

But, cutting and pasting into another folder works!
Attachments
Screenshot.png
Screenshot.png (87.19 KiB) Viewed 2062 times

freebooter
Posts: 6
Joined: Mon Sep 29, 2014 10:38 pm

Re: Delete action doesn't delete file?

Postby freebooter » Mon Sep 29, 2014 10:51 pm

I had the same problem using xnview on Manjaro linux with XFCE. Delete file, it disappears from view but when going back to that folder the file is back. This was when trying to delete photos on an ntfs partition.

I noticed that there is not a choice of 'send to trash' or 'delete' in xnview. I had also recently found that I couldn't send a file to trash on the ntfs drive using Thunar. I tried deleting a file with xnview from my Home folder and it worked fine ie sent the file to trash.

I fixed the problem of no trash on the ntfs drive and now I can 'delete' files from xnview.

This probably isn't the same problem that others are having but it may be worth checking.

User avatar
xnview
Author of XnView
Posts: 27670
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Delete action doesn't delete file?

Postby xnview » Tue Sep 30, 2014 9:10 am

could you try to disabled Settings>General>File operations>Use recycle bin??
Pierre.

freebooter
Posts: 6
Joined: Mon Sep 29, 2014 10:38 pm

Re: Delete action doesn't delete file?

Postby freebooter » Tue Sep 30, 2014 6:38 pm

I don't know whether my post was clear enough but once I had sorted out the Trash problem which was due to XFCE and the way I was mounting the partition in fstab, xnview is working fine with its default setting of 'Use Recycle Bin'. The problem I was having was caused by my setup and not by xnview.

I just thought that the other posters in the thread may have a related issue as the first was talking about file permissions and the second was using xnview to look at files on a shared drive.

I didn't know about the 'Use Recycle Bin' setting. I have tried it anyway and it works fine. Xnview deletes the files as expected.

cossoft
Posts: 3
Joined: Fri Sep 26, 2014 10:37 pm

Re: Delete action doesn't delete file?

Postby cossoft » Sat Oct 11, 2014 12:47 am

freebooter, Hi.

Could you please post your fstab mount command for the share with your piccies? And, why have you mounted the share? For most things gvfs allows access to shares without mounting them. The current Ubuntu (what I'm using - 14.04LTS) documentation suggests that there's no need for mounting such shares.

Anyway, I upgraded XNViewMP to v0.69 and the delete situation has gotten worse. I can't delete any shared files now, with or without turning off the trash option. It does seem that this problem only affects the shared drive files though. Those on local folders can be successfully deleted. I can delete from the shared drive easily using Nautilus file manager, so I'm stuck for a solution to this problem... I've had a unix sysadmin look at the drive permissions on the share and they seem fine.

Is XNViewMP incompatible with linux's gvfs virtual file system? Can anyone else confirm whether or not they can delete from unmounted shared drives using gvfs?

vedavrata
Posts: 14
Joined: Wed Apr 07, 2010 6:44 am
Location: Odesa, Ukraine
Contact:

'Delete' doesn't delete file: XnViewMP 0.72, Xubuntu, NTFS.

Postby vedavrata » Wed May 06, 2015 11:23 am

freebooter wrote:I had the same problem using xnview on Manjaro linux with XFCE. Delete file, it disappears from view but when going back to that folder the file is back. This was when trying to delete photos on an ntfs partition.
I noticed that there is not a choice of 'send to trash' or 'delete' in xnview. I had also recently found that I couldn't send a file to trash on the ntfs drive using Thunar. I tried deleting a file with xnview from my Home folder and it worked fine ie sent the file to trash.
I fixed the problem of no trash on the ntfs drive and now I can 'delete' files from xnview.
This probably isn't the same problem that others are having but it may be worth checking.

i have the same problem:
XnViewMP; Version 0.72 x64 (Dec 19 2014); Libformat version 6.64
Ubuntu 15.04; XFCE (Xubuntu).
FS = NTFS.

When i try to delete file/files, XnViewMP says that "deleted", and even it/they disappear from the file-list (the thumbnails), but it remains on the the file-system (disk).
If i do "refresh" (F5), then "deleted" file/files return inti the file-list (the thumbnails).

This error persists in both cases: "Use recycle bin" = 'ON' or 'OFF'
("delete to recycle bin" or "delete without recycle bin").

Kindly help.

User avatar
oops66
XnThusiast
Posts: 1998
Joined: Tue Jul 17, 2007 1:17 am
Location: France

Re: 'Delete' doesn't delete file: XnViewMP 0.72, Xubuntu, NT

Postby oops66 » Wed May 06, 2015 7:57 pm

vedavrata wrote:This error persists in both cases: "Use recycle bin" = 'ON' or 'OFF'
("delete to recycle bin" or "delete without recycle bin")...
Kindly help.

Hello,
Maybe you can try this way ?
viewtopic.php?p=125911#p125911
XnViewMP 0.82 Linux X64 - Ubuntu 16.04 LTS - X64

dandv
Posts: 28
Joined: Sat Nov 08, 2008 10:46 pm
Location: Silicon Valley
Contact:

Re: Delete action doesn't delete file?

Postby dandv » Tue Jan 10, 2017 2:58 pm

2+ years later, I have the same problem with XnViewMP 0.83 on Ubuntu - if Use Recycle Bin is enabled, deletion does nothing, silently. I spent a good half hour cleaning up a large directory of pictures, only to find out none were deleted. :evil:

The files were on an NTFS partition, if that helps.

After disabling the Recycle Bin option, deletion works.

User avatar
xnview
Author of XnView
Posts: 27670
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Delete action doesn't delete file?

Postby xnview » Tue Jan 10, 2017 3:26 pm

dandv wrote:2+ years later, I have the same problem with XnViewMP 0.83 on Ubuntu - if Use Recycle Bin is enabled, deletion does nothing, silently. I spent a good half hour cleaning up a large directory of pictures, only to find out none were deleted. :evil:

The files were on an NTFS partition, if that helps.

After disabling the Recycle Bin option, deletion works.

i can't reproduce, do you have gvfs-trash on your system?
Pierre.


Return to “MP - General Support”

Who is online

Users browsing this forum: No registered users and 1 guest