Empty XnView after start (1.70 on MacOSX)

Questions, suggestions, and answers for XnView on MacOS X

Moderators: XnTriq, xnview

Schattenreiter

Empty XnView after start (1.70 on MacOSX)

Postby Schattenreiter » Thu Sep 15, 2005 9:15 pm

XnView 1.70 @ MacOSX

Hi,

first of, thank you for the new Version. It's way more stable and even faster than 1.68! *bow*

But, well, I have only one complain :| :
Whenever I launch Xnview, it launches X11 (as it should), but then nothing happens; there is only the empty Xnview about (view-)option available (basically, it doesn't launch).
Only if I start X11 beforehand, and then Xnview, it works fine (and the whole program is available).

Nothing serious, though, just a small inconvenience. ;)

I am using a MacMini with OSX10.4.2 including all patches, and ATI4.5.5 display drivers.

Greetz!

User avatar
xnview
Author of XnView
Posts: 27687
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Empty XnView after start (1.70 on MacOSX)

Postby xnview » Fri Sep 16, 2005 10:24 am

Schattenreiter wrote:first of, thank you for the new Version. It's way more stable and even faster than 1.68! *bow*

But, well, I have only one complain :| :
Whenever I launch Xnview, it launches X11 (as it should), but then nothing happens; there is only the empty Xnview about (view-)option available (basically, it doesn't launch).
Only if I start X11 beforehand, and then Xnview, it works fine (and the whole program is available).

Empty XnView?? You means the menu bar?
Pierre.

Schattenreiter

Re: Empty XnView after start (1.70 on MacOSX)

Postby Schattenreiter » Fri Sep 16, 2005 4:06 pm

xnview wrote:Empty XnView?? You means the menu bar?

Yes. Sorry. Should have explained that in more detail.

There is only the OSX-xnview menu bar, with the "about" option.

If I start X11 beforehand, xnview launches, but there is no osx-menu bar available (sorry, totally forgotten to add that).

Here are two screens (hope they're not too large):

Launched with xnview-icon (active in taskbar):

Image

Second one launched after x11 (no active xnviw-icon in taskbar):

Image


Hope that helps. :)

User avatar
xnview
Author of XnView
Posts: 27687
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Empty XnView after start (1.70 on MacOSX)

Postby xnview » Sat Sep 17, 2005 11:51 am

Schattenreiter wrote:
xnview wrote:Empty XnView?? You means the menu bar?

Yes. Sorry. Should have explained that in more detail.

There is only the OSX-xnview menu bar, with the "about" option.

If I start X11 beforehand, xnview launches, but there is no osx-menu bar available (sorry, totally forgotten to add that).

Here are two screens (hope they're not too large):

Perhaps a problem with OS 10.4...
Pierre.

Schattenreiter

Re: Empty XnView after start (1.70 on MacOSX)

Postby Schattenreiter » Sat Sep 17, 2005 12:31 pm

xnview wrote:Perhaps a problem with OS 10.4...
'kay. I'll try it with Panther later, and let you know the results.

Schattenreiter

Postby Schattenreiter » Mon Sep 19, 2005 5:39 pm

Doesn't launch in Panther at all.

User avatar
xnview
Author of XnView
Posts: 27687
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Postby xnview » Tue Sep 20, 2005 7:57 am

Schattenreiter wrote:Doesn't launch in Panther at all.

Even with the new zip file?
Pierre.

User avatar
Schattenreiter
Posts: 43
Joined: Mon Sep 19, 2005 5:46 pm
Location: Berlin, Germany
Contact:

Postby Schattenreiter » Sat Sep 24, 2005 10:14 am

xnview wrote:Even with the new zip file?

Okay, I've checked again with the new zip-file (sorry for my lack of speed, but I don't like to reboot my machine ;) );

OSX10.3.9: Launches Xnview, but only in pure X11-Unix mode - xnview-icon quits right after the launch of X11. No OSX-xnview menu bar.

OSX10.4.2: No change at all.

Otherwise everything else works just fine. :)

Plushy

XnView in 10.4

Postby Plushy » Fri Oct 21, 2005 9:19 pm

When I'm running it from Icon it just dissapears immidiately.
I've tried to run it from xterm:
that message what I've got:
-------------------------------------
iplush:/Applications/XnView.app/Contents/MacOS plush$ ./XnView
21:22: syntax error: No user interaction allowed. (-1713)
plush has no X11 DISPLAY open
-------------------------------------------
using XnView many years for windoze, now trying to switch to mac.

Rexx

Postby Rexx » Sun Oct 23, 2005 9:47 am

I've not been able to get it to run from x11 terminal at all. Instead I did "show contents" on the package, then extracted the folders to the desktop. Running the xnview program from within the macosx folder made it work straight away.
There's evidently some problem with the way it's packaged up.

User avatar
xnview
Author of XnView
Posts: 27687
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: XnView in 10.4

Postby xnview » Mon Oct 24, 2005 7:23 am

Plushy wrote:When I'm running it from Icon it just dissapears immidiately.
I've tried to run it from xterm:
that message what I've got:
-------------------------------------
iplush:/Applications/XnView.app/Contents/MacOS plush$ ./XnView
21:22: syntax error: No user interaction allowed. (-1713)
plush has no X11 DISPLAY open
-------------------------------------------
using XnView many years for windoze, now trying to switch to mac.

Do you have X11 server?
Pierre.

User avatar
xnview
Author of XnView
Posts: 27687
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Postby xnview » Mon Oct 24, 2005 7:23 am

Rexx wrote:I've not been able to get it to run from x11 terminal at all. Instead I did "show contents" on the package, then extracted the folders to the desktop. Running the xnview program from within the macosx folder made it work straight away.
There's evidently some problem with the way it's packaged up.

Which OSX do you have?
Pierre.

Guest

Re: XnView in 10.4

Postby Guest » Mon Oct 31, 2005 11:35 am

xnview wrote:
Plushy wrote:When I'm running it from Icon it just dissapears immidiately.
I've tried to run it from xterm:
that message what I've got:
-------------------------------------
iplush:/Applications/XnView.app/Contents/MacOS plush$ ./XnView
21:22: syntax error: No user interaction allowed. (-1713)
plush has no X11 DISPLAY open
-------------------------------------------
using XnView many years for windoze, now trying to switch to mac.

Do you have X11 server?


probably yes :) because other X11 applications are running well.
and when I've tried to install X11 from the link on XnView donload page
I've got message that I have newer version of X11 installed.
How can I chek exactly ? I'm newbie dummy with mac unfortunately :(

User avatar
xnview
Author of XnView
Posts: 27687
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: XnView in 10.4

Postby xnview » Mon Oct 31, 2005 1:11 pm

Anonymous wrote:
xnview wrote:
Plushy wrote:When I'm running it from Icon it just dissapears immidiately.
I've tried to run it from xterm:
that message what I've got:
-------------------------------------
iplush:/Applications/XnView.app/Contents/MacOS plush$ ./XnView
21:22: syntax error: No user interaction allowed. (-1713)
plush has no X11 DISPLAY open
-------------------------------------------
using XnView many years for windoze, now trying to switch to mac.

Do you have X11 server?


probably yes :) because other X11 applications are running well.
and when I've tried to install X11 from the link on XnView donload page
I've got message that I have newer version of X11 installed.
How can I chek exactly ? I'm newbie dummy with mac unfortunately :(

Could you try from a shell console, XnView.app/Contents/MacOS/XnView
Pierre.

=CTE=

Re: XnView in 10.4

Postby =CTE= » Tue Nov 01, 2005 9:25 am

Anonymous wrote:
xnview wrote:Do you have X11 server?


probably yes :) because other X11 applications are running well.
and when I've tried to install X11 from the link on XnView donload page
I've got message that I have newer version of X11 installed.
How can I chek exactly ? I'm newbie dummy with mac unfortunately :(


I won't say that you are running X11 server just because other X11 apps are running well ;)

But if you are running OS X 10.4, then the download link will NOT work, because the X11 version that is downloadable from Apple's site works only with 10.3.x

You have to install X11 for Tiger (10.4) from your Tiger Installation Disk then (Can be found, if you select "Install Bundled Software only" and hit "Command + R", that will open the folder with the software packages. There you just doubleclick "X11User"). But this would just reinstall the X11 version you already HAVE installed - and that one's NEWER than the one found following the download link...

=CTE=


Return to “XnView Mac OS X”

Who is online

Users browsing this forum: No registered users and 1 guest