2.36: Sensitivity of Arrows for navigating between pictures

Bugs found in XnView Classic. Please report only one bug per topic!

Moderators: XnTriq, xnview

Hans L
Posts: 97
Joined: Tue Mar 03, 2009 6:12 pm

2.36: Sensitivity of Arrows for navigating between pictures

Postby Hans L » Sat Aug 20, 2016 6:04 pm

Hello:

When I open an image file (the first or the last) in a directory in Windows Explorer, both arrows for moving between pictures are blue.

When you click these arrows and you step through the files in a directory, and you get to the first or last picture in the directory, the respective arrow turns white.

It would be good, and logical, if the respective arrow turned white also when you opened the first or last picture in a directory. Would that be possible?

Hans L

User avatar
xnview
Author of XnView
Posts: 27356
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Arrow for moving between pictures

Postby xnview » Sun Aug 21, 2016 1:46 pm

Options>View>Misc>Loop on filelist
Pierre.

Hans L
Posts: 97
Joined: Tue Mar 03, 2009 6:12 pm

Re: Arrow for moving between pictures

Postby Hans L » Sun Aug 21, 2016 3:01 pm

Hello Xnview:

I think you misunderstood me. If I check the box you refer to, when I am at the last picture in the list, and I click the right arrow, I get the first picture in the list (as you very well know, but I mention it for anyone else that may read this).

However, what I am talking about is this: When I open the first file in a directory, I would like to see the left arrow white (indicating that I can only "scroll" down the files in the directory), and when I open the last file in a directory, I would like to see the right arrow white (indicating that I can only "scroll" up the files in the directory),

Hope this explains it better.

Regards,

Hans L

User avatar
XnTriq
Moderator & Librarian
Posts: 4917
Joined: Sun Sep 25, 2005 3:00 am
Location: Ref Desk

Re: Arrow for moving between pictures

Postby XnTriq » Sun Aug 21, 2016 7:45 pm

Does Explorer use the same sort order in the active directory as XnView, Hans L?

Hans L
Posts: 97
Joined: Tue Mar 03, 2009 6:12 pm

Re: Arrow for moving between pictures

Postby Hans L » Sun Aug 21, 2016 8:03 pm

XnTriq wrote:Does Explorer use the same sort order in the active directory as XnView, Hans L?


I remember (kinda' vaguely) that once, Windows Explorer did not have the same sort order on my computer, and I think I asked in this group, and got a tip to set something either in Explorer or Xnview so as to get the same sort order, In any event, the sort order is the same.

When I open, say, the first file in a directory, and the left key in Xnview is blue, and I click on it, nothing happens (which is correct, but it would be good if the key was white to indicate that it is no use clicking on it :-)

Regards,

Hans L

User avatar
XnTriq
Moderator & Librarian
Posts: 4917
Joined: Sun Sep 25, 2005 3:00 am
Location: Ref Desk

Re: Arrow for moving between pictures

Postby XnTriq » Sun Aug 21, 2016 8:15 pm


Hans L
Posts: 97
Joined: Tue Mar 03, 2009 6:12 pm

Re: Arrow for moving between pictures

Postby Hans L » Sun Aug 21, 2016 8:54 pm


User avatar
XnTriq
Moderator & Librarian
Posts: 4917
Joined: Sun Sep 25, 2005 3:00 am
Location: Ref Desk

Re: Arrow for moving between pictures

Postby XnTriq » Sun Aug 21, 2016 9:00 pm

Hans L wrote:Yes, both arrows are blue.

OK, I've moved this topic to “Bug Reports”.

Hans L
Posts: 97
Joined: Tue Mar 03, 2009 6:12 pm

Re: Arrow for moving between pictures

Postby Hans L » Sun Aug 21, 2016 9:27 pm

XnTriq wrote:
Hans L wrote:Yes, both arrows are blue.

OK, I've moved this topic to “Bug Reports”.


Great. Hope something will be done,because, in your hyperlinks, this was discussed in detail a loooong time ago :-)

Hans L

User avatar
XnTriq
Moderator & Librarian
Posts: 4917
Joined: Sun Sep 25, 2005 3:00 am
Location: Ref Desk

Re: Arrow for moving between pictures

Postby XnTriq » Sun Aug 21, 2016 9:45 pm

Hans L wrote:Great. Hope something will be done,because, in your hyperlinks, this was discussed in detail a loooong time ago :-)

Let's not forget that Pierre is the only developer of all these feature-rich and complex programs. He constantly has to weigh one against the other: Spending time on minor bugs that perhaps require more time to fix vs. implementing a new feature that's requested by a lot of users. ;-)

Hans L
Posts: 97
Joined: Tue Mar 03, 2009 6:12 pm

Re: Arrow for moving between pictures

Postby Hans L » Mon Aug 22, 2016 12:12 am

XnTriq wrote:
Hans L wrote:Great. Hope something will be done,because, in your hyperlinks, this was discussed in detail a loooong time ago :-)

Let's not forget that Pierre is the only developer of all these feature-rich and complex programs. He constantly has to weigh one against the other: Spending time on minor bugs that perhaps require more time to fix vs. implementing a new feature that's requested by a lot of users. ;-)


I am acutely aware of this, and my 'hope' above was only just that ... a hope ... tempered by the fact that last time, this issue did not get enough priority. I'll continue to hope.

Hans L

User avatar
XnTriq
Moderator & Librarian
Posts: 4917
Joined: Sun Sep 25, 2005 3:00 am
Location: Ref Desk

Re: Arrow for moving between pictures

Postby XnTriq » Mon Aug 22, 2016 12:30 am

Hans L wrote:I'll continue to hope.

:-D We all do! I was just trying to put things into perspective and ask everyone for patience.

BTW: The main reason for compiling my infamous “lists of links” is to give us all an overview which requests are most important.

Hans L
Posts: 97
Joined: Tue Mar 03, 2009 6:12 pm

Re: 2.36: Sensitivity of Arrows for navigating between pictures

Postby Hans L » Sun Apr 23, 2017 4:13 pm

Hello:

I thought this was fixed, but I am not sure. In any event, I get the blue button when I open the *first* file in a list and "Tools > Options > View > Misc > Loop on filelist" is UNchecked.

Pierre, you asked above: "Does Explorer use the same sort order in the active directory as XnView, Hans L?"

Not shure what you are aiming at. Would you please explain? Thank you!

Hans L


Return to “Classic - Bug Reports”

Who is online

Users browsing this forum: No registered users and 2 guests