Compatiblity with Windows XP

Ask for help and post your question on how to use XnView Classic.

Moderators: XnTriq, xnview

ghmxkd
Posts: 1
Joined: Fri Mar 10, 2017 6:25 am

Compatiblity with Windows XP

Postby ghmxkd » Fri Mar 10, 2017 6:29 am

Is XnView 2.39 supposed to run on Windows XP? I"m getting this error:
The procedure entry point _ftol2_sse could not be located in the dynamic link library msvcrt.dll.

User avatar
xnview
Author of XnView
Posts: 27343
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Compatiblity with Windows XP

Postby xnview » Fri Mar 10, 2017 10:36 am

is it XP SP3?
Pierre.

TrevorSld
Posts: 2
Joined: Wed Mar 22, 2017 6:11 am

Re: Compatiblity with Windows XP

Postby TrevorSld » Wed Mar 22, 2017 6:13 am

Does the Service Pack make a difference? If so I have a computer running SP2.

User avatar
xnview
Author of XnView
Posts: 27343
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Compatiblity with Windows XP

Postby xnview » Wed Mar 22, 2017 7:50 am

TrevorSld wrote:Does the Service Pack make a difference? If so I have a computer running SP2.

yes, you need SP3 to run XnView
Pierre.

Noel80
Posts: 7
Joined: Tue Nov 19, 2013 10:35 am

Re: Compatiblity with Windows XP

Postby Noel80 » Wed Apr 19, 2017 8:37 pm

Same problem with win Xp SP3. (both Xnview and xnconvert)
I found out "the bug" some time ago. It is the last webp plugin. Just replace it with an older one.
I got webp plugin from xnconvert 1.71 and I put it into plugin folder of the last version, and error went away.
Attachments
webp.zip
(227.74 KiB) Downloaded 19 times

User avatar
xnview
Author of XnView
Posts: 27343
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Compatiblity with Windows XP

Postby xnview » Mon Apr 24, 2017 6:56 am

Noel80 wrote:Same problem with win Xp SP3. (both Xnview and xnconvert)
I found out "the bug" some time ago. It is the last webp plugin. Just replace it with an older one.
I got webp plugin from xnconvert 1.71 and I put it into plugin folder of the last version, and error went away.

Please re-download the package, i've updated the webp.dll
Pierre.

Noel80
Posts: 7
Joined: Tue Nov 19, 2013 10:35 am

Re: Compatiblity with Windows XP

Postby Noel80 » Mon Apr 24, 2017 1:04 pm

xnview wrote:
Noel80 wrote:Same problem with win Xp SP3. (both Xnview and xnconvert)
I found out "the bug" some time ago. It is the last webp plugin. Just replace it with an older one.
I got webp plugin from xnconvert 1.71 and I put it into plugin folder of the last version, and error went away.

Please re-download the package, i've updated the webp.dll


Now Xnview works fine, thanks!
PS: Xnconvert needs to be updated as well.


Return to “Classic - General Support”

Who is online

Users browsing this forum: No registered users and 2 guests