0.86: "GPS" Overlay icon not shown

Moderators: cday, XnTriq, helmut, xnview, Dreamer

Jobi
Posts: 11
Joined: Tue Apr 11, 2017 3:47 pm

0.86: "GPS" Overlay icon not shown

Postby Jobi » Mon May 22, 2017 12:55 pm

XnView: MP 0.86 - 64-bit
OS: Windows 7 - 64-bit / Windows 8.1 - 64-bit

Effect: XnViewMP fails to show (mostly) the GPS overlay icon although there are correct Exif/IPTC GPS data

To reproduce:
(0. Take images with GPS data and delete XMP data with "exiftool -P -overwrite_original -XMP:all= ."
I just discovered that it also happens if there are imbedded XMP data, but chances are worse without any XMP. Before I thought that behaviour only occurs while there are no XMP-data. My files are nearly all geo-tagged, only using Exif/IPTC and do not contain any XMP.)

1. Choose any folder containing images with embedded Exif/IPTC GPS-data. If this folder is read for the very first time XnViewMP will probably show the "GPS"-indicator.
2. Refresh file/image list (F5). With some luck the GPS icon will be still displayed - for me: mainly not.
3. In this case of luck choose another folder from the left folder pane and then go back to the previous folder.
4. In most cases XnViewMP "forgets" to display the GPS overlay icon. But the Exif image info shows that GPS data are available, even the tab "GPS" is displayed and will show the correct location on the map. (See screenshot)

Notice: In the case XnViewMP fails to display the "GPS"-icon(s), the custom label {EXIF:Latitude}; {EXIF:Longitude} will be blank too.
"Rebuilding Thumbnails" brings back the GPS-information (overlay icon/custom label), but only temporary up to the moment you choose another directory and go back.

OverlayIcon-Bug_.png


Actual behaviour (bug): XnViewMP does not show the GPS overlay icon although there are valid GPS data (Exif/IPTC) :bug:

Expected behaviour: XnViewMP should always display the GPS overlay icon when there are Exif/IPTC GPS data included.

XnView (Classic v2.40) works correctly and shows the GPS overlay icon "GPS" (indicating the Exif/IPTC GPS data)
As far as I remember, also XnViewMP 0.85 was indicating correctly "GPS" for Exif/IPTC GPS data.

Edit/Update
There are some JPGs in my folders where XnView MP always shows correctly the GPS indicator (even when I change the directory). After some investigation I discovered there is one thing those files have in common: they do not include Exif-thumbnails.
But on the other hand side: Not "all JPGs without Exif-thumbnails" are indicated correctly with the GPS-icon!

With kind regards,
Jobi

User avatar
xnview
Author of XnView
Posts: 27690
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: 0.86: "GPS" Overlay icon not shown

Postby xnview » Thu Jun 15, 2017 12:06 pm

I can't reproduce, could you send me a picture file?
Pierre.

Jobi
Posts: 11
Joined: Tue Apr 11, 2017 3:47 pm

Re: 0.86: "GPS" Overlay icon not shown

Postby Jobi » Fri Jun 16, 2017 2:37 pm

xnview wrote:I can't reproduce, could you send me a picture file?

Many thanks for your reply.
I was sending you example images via mail.

The topic 0.86: GPS tag is missing in Info column (usually) seems quite similar to my issue.

Kind regards,
Jobi

User avatar
xnview
Author of XnView
Posts: 27690
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: 0.86: "GPS" Overlay icon not shown

Postby xnview » Sat Jun 17, 2017 4:51 pm

O.k., thank you, I can also reproduce the problem. Issue 1264 is fixed in next version.
Pierre.

Jobi
Posts: 11
Joined: Tue Apr 11, 2017 3:47 pm

Re: 0.86: "GPS" Overlay icon not shown

Postby Jobi » Sat Jun 17, 2017 9:18 pm

xnview wrote:O.k., thank you, I can also reproduce the problem. Issue 1264 is fixed in next version.


Thanks you very much.
I hope this will fix also the affected overlay icon "Embedded thumbnail", which was not mentioned in my report.

Regards, Jobi

User avatar
xnview
Author of XnView
Posts: 27690
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: 0.86: "GPS" Overlay icon not shown

Postby xnview » Sat Jul 08, 2017 12:44 pm

This problem is supposed to be fixed in XnView MP 0.87. Please check and confirm the bug fix here.
Pierre.

Jobi
Posts: 11
Joined: Tue Apr 11, 2017 3:47 pm

Re: 0.86: "GPS" Overlay icon not shown

Postby Jobi » Sun Jul 09, 2017 5:51 am

xnview wrote:This problem is supposed to be fixed in XnView MP 0.87. Please check and confirm the bug fix here.

I retested the behaviour in XnView MP 0.87 beta 1.
Everything seems to work as it should and expected, all overlay icons are shown: GPS icons and the embedded thumbnail icons as well (in all views). Very good job! :)
Many, many thanks for that fix, Pierre!

With kind regards,
Jobi


Return to “0.87 Testing – Fixed/Resolved”

Who is online

Users browsing this forum: No registered users and 1 guest