0.86: Wrong thumbnail orientation for raw files

Moderators: cday, XnTriq, helmut, xnview, Dreamer

Germie
Posts: 9
Joined: Sun Apr 30, 2017 2:41 pm

Re: 0.86 Thumbnail orientation

Postby Germie » Wed May 03, 2017 8:47 am

xnview wrote:sorry but i can't reproduce, could you post a screenshot?


Hmmmm. thats odd.
I'm not at the pc with xnviewmp right now. I tested with these files yesterday evening.
It looks precisely as described above. Screenshots -with other files- are in the first post.

Regards
Germie

User avatar
XnTriq
Moderator & Librarian
Posts: 5006
Joined: Sun Sep 25, 2005 3:00 am
Location: Ref Desk

Re: 0.86 Thumbnail orientation

Postby XnTriq » Wed May 03, 2017 3:00 pm

Germie wrote:Essential for reproduction is de creation of an XMP file by adding i.e. a keyword.
After that the portrait thumbnails change to landscape.

Confirmed! I'll be back with step-by-step instructions on how to reproduce this behavior.

User avatar
m.Th.
XnThusiast
Posts: 1370
Joined: Wed Aug 16, 2006 6:31 am
Contact:

Re: 0.86 Thumbnail orientation

Postby m.Th. » Wed May 03, 2017 3:57 pm

xnview wrote:
Germie wrote:Hi Pierre,

Sorry about that.
Try this link instead: https://www.dropbox.com/s/w4120vnwaan49 ... s.zip?dl=0

Regards
Germie

Do you reproduce with these files? there is no orientation field...



...I remember a long time ago in a galaxy far, far away that I've sent you some NEF files and you responded the same. In fact, the problem is more complicated because definitely there IS another factor involved because if one will do a Rebuild Thumbnails on the very same set of files the new thumbs will have the correct orientation.

IIRC then you sent me a debugging version with log viewer enabled and we fixed the issue somehow. However now I don't remember what it was.

Besides that, it is very odd: How "is no orientation field" since the files are SOOC? Perhaps you're looking where it shouldn't? Perhaps the orientation bit is recorded somewhere else more reliably? ...or perhaps your the detection tool isn't written entirely correct?
m. Th.

The Ascetic Experience - The best photos and texts from Holy Mountain (Athos)

- Dark Themed XnViewMP 0.86 64bit & XnView 2.00 x64 on Win7 x64 -

User avatar
XnTriq
Moderator & Librarian
Posts: 5006
Joined: Sun Sep 25, 2005 3:00 am
Location: Ref Desk

Re: 0.86: Wrong thumbnail orientation for raw files

Postby XnTriq » Wed May 03, 2017 7:30 pm

  1. Download sony_cybershot_dsc_rx10_18.arw to an empty folder (e.g. X:\Test\).
  2. Activate the following options in ToolsSettings...:
    • GeneralGeneralRotate images according to EXIF orientation tag
    • ThumbnailMiscUse embedded thumbnail
    • MetadataIPTC & XMPKeywordsExport DB Category to XMP Subject and IPTC Keyword
    • MetadataIPTC & XMPKeywordsUpdate or create XMP Sidecar
    • CatalogCatalogEnable thumbnail caching
    • ViewViewCamera RAW, use [ Embedded preview ]
  3. Point the browser to X:\Test\.
  4. Select the thumbnail (portrait) for sony_cybershot_dsc_rx10_18.arw.
  5. Right-click the thumbnail to get to the context menu.
  6. Go to CategoryPhotographsTravel.
  7. Point the browser to a different folder.
  8. Return to X:\Test\.
    The thumbnail for sony_cybershot_dsc_rx10_18.arw changed from portrait to landscape. :bug:
  9. Select the thumbnail for sony_cybershot_dsc_rx10_18.arw.
  10. Go to ViewRebuild thumbnails.
    The thumbnail for sony_cybershot_dsc_rx10_18.arw changes from landscape to portrait.

<!-- // UPDATE //

The problem doesn't occur if ToolsSettings...ThumbnailMiscUse embedded thumbnail is deactivated.

// UPDATE //-->


BTW: In my tests, the XMP sidecar file…

Code: Select all

<x:xmpmeta xmlns:x="adobe:ns:meta/" x:xmptk="XMP Core 5.5.0">
   <rdf:RDF xmlns:rdf="http://www.w3.org/1999/02/22-rdf-syntax-ns#">
      <rdf:Description rdf:about=""
            xmlns:xmp="http://ns.adobe.com/xap/1.0/"
            xmlns:MicrosoftPhoto="http://ns.microsoft.com/photo/1.0/"
            xmlns:dc="http://purl.org/dc/elements/1.1/"
            xmlns:lr="http://ns.adobe.com/lightroom/1.0/">
         <xmp:Rating>0</xmp:Rating>
         <xmp:Label>None</xmp:Label>
         <MicrosoftPhoto:Rating>0</MicrosoftPhoto:Rating>
         <dc:subject>
            <rdf:Bag>
               <rdf:li>Travel</rdf:li>
            </rdf:Bag>
         </dc:subject>
         <lr:hierarchicalSubject>
            <rdf:Bag>
               <rdf:li>Photographs|Travel</rdf:li>
            </rdf:Bag>
         </lr:hierarchicalSubject>
      </rdf:Description>
   </rdf:RDF>
</x:xmpmeta>

… wasn't created unless I ran the Update files from catalog command in the View menu.

User avatar
XnTriq
Moderator & Librarian
Posts: 5006
Joined: Sun Sep 25, 2005 3:00 am
Location: Ref Desk

Re: 0.86 Thumbnail orientation

Postby XnTriq » Wed May 03, 2017 8:45 pm

m.Th. wrote:Saw it sporadically in 0.86 again after a looong time. Used to appear in older versions. Same settings like Germie. Working with CR2 files.

m.Th. wrote:...I remember a long time ago in a galaxy far, far away that I've sent you some NEF files and you responded the same.


User avatar
helmut
Posts: 8116
Joined: Sun Oct 12, 2003 6:47 pm
Location: Frankfurt, Germany

Re: 0.86: Wrong thumbnail orientation for raw files

Postby helmut » Sun May 07, 2017 8:32 am

XnTriq, from what I can see you could reproduce the problem, right?

User avatar
XnTriq
Moderator & Librarian
Posts: 5006
Joined: Sun Sep 25, 2005 3:00 am
Location: Ref Desk

Re: 0.86: Wrong thumbnail orientation for raw files

Postby XnTriq » Sun May 07, 2017 11:00 am

helmut wrote:XnTriq, from what I can see you could reproduce the problem, right?

Correct (see steps 1 through 10). I hope that's the issue described by Germie and m.Th.

Germie
Posts: 9
Joined: Sun Apr 30, 2017 2:41 pm

Re: 0.86: Wrong thumbnail orientation for raw files

Postby Germie » Sun May 07, 2017 7:03 pm

XnTriq wrote: I hope that's the issue described by Germie and m.Th.


That is correct!

Regards
Germie

User avatar
xnview
Author of XnView
Posts: 27690
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: 0.86: Wrong thumbnail orientation for raw files

Postby xnview » Wed Jun 07, 2017 5:51 pm

XnTriq wrote:Download sony_cybershot_dsc_rx10_18.arw to an empty folder (e.g. X:\Test\).

the file is no more available :(
Pierre.

User avatar
XnTriq
Moderator & Librarian
Posts: 5006
Joined: Sun Sep 25, 2005 3:00 am
Location: Ref Desk

Re: 0.86: Wrong thumbnail orientation for raw files

Postby XnTriq » Wed Jun 07, 2017 8:45 pm

xnview wrote:
XnTriq wrote:Download sony_cybershot_dsc_rx10_18.arw to an empty folder (e.g. X:\Test\).

the file is no more available :(

You've got mail ;-)

User avatar
xnview
Author of XnView
Posts: 27690
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: 0.86: Wrong thumbnail orientation for raw files

Postby xnview » Sat Jun 17, 2017 6:28 pm

O.k., thank you, I can also reproduce the problem. Issue 1213 is fixed in next version.
Pierre.

User avatar
xnview
Author of XnView
Posts: 27690
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: 0.86: Wrong thumbnail orientation for raw files

Postby xnview » Sat Jul 08, 2017 12:47 pm

This problem is supposed to be fixed in XnView MP 0.87. Please check and confirm the bug fix here.
Pierre.

User avatar
XnTriq
Moderator & Librarian
Posts: 5006
Joined: Sun Sep 25, 2005 3:00 am
Location: Ref Desk

Re: 0.86: Wrong thumbnail orientation for raw files

Postby XnTriq » Wed Jul 19, 2017 2:30 am

xnview wrote:This problem is supposed to be fixed in XnView MP 0.87. Please check and confirm the bug fix here.

Confirmed fixed :bugfixed:


Return to “0.87 Testing – Fixed/Resolved”

Who is online

Users browsing this forum: No registered users and 0 guests