0.84: Tabbing impossible in dialogs with multi-line fields

Moderators: cday, XnTriq, helmut, xnview, Dreamer

User avatar
helmut
Posts: 8116
Joined: Sun Oct 12, 2003 6:47 pm
Location: Frankfurt, Germany

0.84: Tabbing impossible in dialogs with multi-line fields

Postby helmut » Sun Mar 26, 2017 12:51 am

XnView: MP 0.84 - 64 bit
OS: Windows 10 - 64bit

In all(?) multiline textfields the user cannot navigate to the next field by pressing "Tab" key. Neither Tab key works, nor Strg+Tab.

Effect: User cannot fill out dialogs using keyboard, only.

To reproduce:
1. In XnView browser select one or multiple images.
2. Select Create » Contact sheet...
3. In "Create contact sheet" dialog press Tab key till focus is in field "Information".
4. Press Tab key one more time
Actual behaviour (bug): A tab character is inserted into the Information field. :bug:

Expected behaviour: Tab key should tab to the next field. Strg+Tab should insert a tab character into the Information field. (On Windows Strg+Tab is de-facto standard keyboard assignment for inserting tab character).

Note: The above example is for the dialog "Create contact sheet" but it applies for other dialogs like "Edit IPTC", too.

User avatar
helmut
Posts: 8116
Joined: Sun Oct 12, 2003 6:47 pm
Location: Frankfurt, Germany

Re: 0.84: Tabbing impossible in dialogs with multi-line fields

Postby helmut » Fri May 12, 2017 12:50 pm

Could someone please try and reproduce the reported problem?

User avatar
xnview
Author of XnView
Posts: 27667
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: 0.84: Tabbing impossible in dialogs with multi-line fields

Postby xnview » Mon Jun 19, 2017 12:57 pm

O.k., thank you, I can also reproduce the problem. Issue 1267 is fixed in next version.
Pierre.

User avatar
xnview
Author of XnView
Posts: 27667
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: 0.84: Tabbing impossible in dialogs with multi-line fields

Postby xnview » Sat Jul 08, 2017 12:43 pm

This problem is supposed to be fixed in XnView MP 0.87. Please check and confirm the bug fix here.
Pierre.


Return to “0.87 Testing – Retest”

Who is online

Users browsing this forum: No registered users and 1 guest